Pura X no power

Posted over 1 year ago by Le Tien Hiep

Post a topic
Un Solved
L
Le Tien Hiep

My Pura X no longer lights up, even though I plugged it in to another outlet

3 Votes


6 Comments

Sorted by
I

Ian Dunn posted about 1 month ago

Same thing for me. I have electrical experience so tried a few things: The power brick was supplying the correct 12 volts all the way up to the main circuit board behind the display screen - I checked this up unplugging the power cable from the circuit board and confirmed 12V on the cable. As soon as the cable is plugged back into the circuit board the voltage drops to 0V. So there is a problem when an electrical load is applied. This could be 3 things:

1. Faulty Power Brick. I tried a spare 12V power brick i have and still the same problem, so it is not that (for me at least).

2. Faulty circuit board.

3. The motor is trying to turn but is stuck. Unlikely as I can't hear any strain on the motor or feel any warmth in the power brick which could happen when under stress.  


My guess is '2' - faulty circuit board. This 'no power' issue appears quite common so I guess there is a general design flaw in the circuit board that causes it to fail quickly. There's not much an end user can do here as I doubt Petkit would send a replacement circuit board.

0 Votes

m

martina contiero posted 4 months ago

News?

0 Votes

H

Hecsus posted 4 months ago

Same problem

0 Votes

S

Sarah Strong Wilson posted 6 months ago

I just unboxed and set mine up... it won't power on & I've tried 4 different outlets...


Any advice? 

0 Votes

C

Cuong Phan posted 8 months ago

The same issue, have you guys any idea to resolve this problem ?

0 Votes

Y

Yo Momma posted about 1 year ago

Figure out the problem? Mine quut worki g as well, i even replaced plug and still nothing...

0 Votes

Login or Sign up to post a comment